Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 30, 2025 - 06:00 UTC
Scheduled
We will be undertaking scheduled maintenance during this time. All WP Media websites will not be accessible. Activation of plugins will not be possible during this timeframe. Some SaaS features of WP Rocket & Imagify will be affected.
Posted Oct 28, 2025 - 17:54 UTC
This scheduled maintenance affected: Imagify (Imagify Website, Imagify API, Imagify WebApp), RocketCDN (RocketCDN Website), and WP Rocket (WP Rocket Website).