Email delivery provider is facing issues to deliver our emails

Incident Report for WP Media

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 22:37 UTC

Update

Most transactional emails are now delivered through another provider.
We are still fixing an issue with the support contact form.
Posted Mar 10, 2025 - 14:31 UTC

Identified

Our provider is still facing issues. We are working on integrating another provider for emails as a backup.
Posted Mar 10, 2025 - 11:29 UTC

Investigating

Emails from Imagify are not sent properly as an incident is ongoing with our email provider. We are in communication with them to solve the issue and restore the functionnality.
Posted Mar 07, 2025 - 18:51 UTC
This incident affected: Imagify (Imagify Website).