WP Rocket incompatibility with WordPress 7.1

Incident Report for WP Media

Resolved

The hotfix 3.23.2.2 is reported to fix the issue by many users.
If you still face issues, please contact our support directly to they can help you & investigate your specific issue: https://wp-rocket.me/support/
Posted Aug 20, 2026 - 10:15 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 20, 2026 - 09:00 UTC

Monitoring

A hotfix has been released (WP Rocket v3.23.2.2). We are monitoring feedback from users to ensure the situation is completely solved.
Posted Aug 20, 2026 - 08:14 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 20, 2026 - 06:15 UTC

Update

A hotfix is being prepared.
A manual mitigation for already impacted users is described here: https://docs.wp-rocket.me/article/1927-fatal-error-on-wordpress-7-1
Posted Aug 20, 2026 - 06:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 20, 2026 - 05:44 UTC
This incident affected: WP Rocket (WP Rocket Website, RUCSS service, Rocket Insights).